Auto Login WMS Venue (Update 1 Juni 2021)

Auto Login WMS Venue (Update 1 Juni 2021)

by : Aditya Y Pradhana

Akhir Mei 2021 pagi saya dikerjain lagi dengan sistem telkom WMS dimana auto login untuk akses internet WMS telkom sudah tidak bisa digunakan lagi, akhirnya sementara saya menggunakan logfin manual via browser untuk akses internet WMS.

Sekedar info sistem yang saya gunakan untuk akses ke telkom WMS meggunakan mikrotik SXTsq, untuk disebar ke seluruh rumah.

Setelah riset dan cari referensi sana sini, akhirnya script bisa digunakan juga, ada tambahan reference pada header http post yang dikirim ketika login ke alamat (url) WMS telkom.

Selain itu adajg perubahan gabungan username dari @freeMS menjadi @wms.<digit numerik>

Langkah pertama seperti biasa kita perlu mendapatkan beberapa variable yang diperlukan ketika login WMS. Seperti username, password, gw_id, wlan_id, dan wms_id.

Seluruh variable tersebut bisa dapat kamu dapatkan di halaman login WMS, untuk lebih detail bisa melihat source code halaman tersebut di bagian url.

Source code login WMSSource code login WMS

Setelah mendapatkan seluruh variable yang diperlukan, selanjutnya kita masukan ke daftar variable script auto login WMS.

# Daftar Variable
:local user ""
:local pass ""
:local gwid ""
:local ether ""
:local wlan ""
:local wms ""
:local redirect ""
# Akhir Variable

Langkah pertama didalam script auto login WMS adalah mendapatkan ip address yang diberikan oleh router WMS dengan cara:

:local ip [/ip address get [/ip address find interface="$ether"] address];
:local ip [put [:pick $ip 0 [:find $ip "/"]]];
:if ([:len $ip] = 0) do={
	:log error ("Interface $ether tidak mendapatkan alamat ip --- mencoba mendapatkan...");
	/ip dhcp-client release [find interface="$ether"];
}; 

Jika alamat ip belum tersedia script akan otomatis untuk me-release ip dhcp ulang.

Selanjutnya kita dapatkan MAC Address dan juga Gateway dari router yang digunakan untuk mengakses WMS.

:local mac [/interface get [find name="$ether"] mac-address];
:local gateway [/ip dhcp-client get [find interface="$ether"] gateway];

Selanjutnya generate 4 karakter yang akan digunakan untuk username.

:local num1 [:pick [/system clock get time] 0] 
:local num2 [:pick [/system clock get time] 1] 
:local num3 [:pick [/system clock get time] 3] 
:local num4 [:pick [/system clock get time] 6] 
:local char1 [:pick "abcdefghijklmnopqrstuvwxyz" "$num1$num2"]
:local char2 [:pick "abcdefghijklmnopqrstuvwxyz" "2$num2"]
:local char3 [:pick "abcdefghijklmnopqrstuvwxyz" "1$num4"]
:local user "$user.$char3$char1$char2$wms"

Lakukan proses koneksi ke WMS

:tool fetch mode=https http-header-field="Content-Type: application/x-www-form-urlencoded; charset=UTF-8,User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36,Referer: https://welcome2.wifi.id/login/?gw_id=$gwid&client_mac=$mac&wlan=$wlan&sessionid=0203FFFF7803E5D2-60B372A2&redirect=$redirect" http-method=post http-data="username=$user&password=$pass" url="https://welcome2.wifi.id/wms/auth/authnew/autologin/quarantine.php\?ipc=$ip&gw_id=$gwid&mac=$mac&redirect=$redirect&wlan=$wlan" dst-path=wms.txt;

Selanjutnya simpan, lalu jalankan script. Jika berhasil pada bagian log akan terdapat keterangan Login sukses seperti pada gambar dibawah ini.

Login sukses WMSLogin sukses WMS

Untuk script lengkap dapat kalian download disini.

auto login wms telkom indihome mikrotik download script

Latest Posts: